Chat / support@radicenter.eu

Koduleht ei tööta – PHP versioon uuenenud – Error: reference/function is deprecated

01.01.2014 Uuendasime viimasel legacy serveril PHP versiooni 5.2.* pealt 5.3.28 peale.
Selle kohta on saadetud korduvalt sellel serveril asuvatele klientidele ka teavitusi:
2013-12-11
2013-11-02
2013-07-04

Algselt oli uuendamine ette nähtud 1. jaanuaril 2013, kuid vastu tulles paljude klientide soovile viivitasime uuendusega viimase võimaluseni. Kauem ei olnud uuendust enam võimalik edasi lükata, kuna PHP 5.2 verisoon ei ole ametlikult  toetatud juba 3 aastat.

PHP 5.2 versioon võeti maha 6. jaanuar 2011
Lisainfo: http://php.net/eol.php

Teavitus saadeti Klientide poolt määratud mailiaadressitele.
Teavitus:

---
Lugupeetud klient

Käesolev kiri teatab olulisest muudatusest Radicenteri teenuses.
Juhul, kui te ise ei ole oma kodulehekülje tehniline haldaja, palume edastada see kiri vastavale isikule.

ÜLEMINEK PHP 5.2-LT PHP 5.3-LE 31. DETSEMBRIL 2013
Kuna PHP versioon 5.2 on aegunud ning see ei ole enam ametlikult toetatud
arendajate poolt, peame oma serveritel läbi viima PHP versiooniuuenduse
versioonini 5.3.

Üleminek on vajalik, kuna PHP 5.2 versioonis enam turvaauke ei parandata, lisaks ei toeta see PHP versioon enam uuemaid koduleheküljelahendusi.

Lisainformatsioon muudatuste kohta aadressil: http://php.net/eol.php

Uuendus toimub 31. detsembril 2013. Enamjaolt peaksid
kõik PHP skriptid töötama peale uuendust edasi, kuid võib juhtuda, et mõni
skript siiski lakkab töötamast. Kui kasutate valmistarkvara (Joomla, WordPress,
Drupal, Gallery jms.), siis piisab, kui uuendate selle tarkvara kõige uuema
versioonini. Kui kasutate endavalmistatud skripti, siis peate vastavad muudatused skriptidesse sisse viima ise või laskma seda teha kellelgi teisel.
Täpsem informatsioon PHP 5.3 muudatuste kohta on kättesaadav PHP arendaja
koduleheküljelt:
http://php.net/eol.php
http://www.php.net/manual/en/migration53.php

Juhul kui saate oma kodulehel veateate “… reference is deprecated …” ja teie kodulehe DirectAdmini haldusliides asub serveril: https://212.47.208.158:2222/ – teie veebilehel on vananenud sisuhaldus süsteem mis kasutab iganenud PHP funktsioone ning mida uuem PHP versioon enam ei toeta.

Mida teha:

Soovitame võtta ühendust oma webmasteriga ning paluda tal:
1. Kui kasutate valmistarkvara (Joomla, WordPress,Drupal, Gallery jms.), siis piisab, kui uuendate selle tarkvara kõige uuema versioonini.
2. Kui kasutate endavalmistatud skripti, siis peate vastavad muudatused skriptidesse sisse viima ise või laskma seda teha kellelgi teisel.

Küsimused/vastused

K: Mina ei ole sellega nõus olnud, miks te seda tegite?
V: Kuna PHP versioon 5.2 ei olnud enam turvaline ja toetatud, viisime uuendused sisse. Kliente on piisava ajaga ette teavitatud tulevatest muudatustest.

K: Aga äkki saate minul PHP varasema versiooni ikkagi aktiveerida?
V: EI. Kõikidel meie serveritel on globaalselt kasutusel hetkeseisuga PHP 5.3.* ning mitteturvalist nö. legacy versiooni ei aktiveerita.

K: Mina pole seda maili kätte saanud!
V: Radicentri poolt on teavitusmail välja saadetud kõikidele klientidele, kellel on sellel serveril konto. Mailiaadressid on võetud Radicenteri kliendialast kas kontaktmailid või tehnilised kontaktid kindlal kontol. Kõik teavituskirjad on kohale toimetatud.
Kui juhtub et te ei ole maili kätte saanud:
1. Kontrollige kliendialas olevat teavitusmaili aadressi et see oleks korrektne. (Klient on ise kohustatud hoidma kontaktteavet ajakohasena – valede kontaktandmete korral Radicenter ei vastuta teavituste mitte kättesaamise eest.)
2. Kontrollige oma mailboksi rämpsposti kausta (osadel klientidel on teavitusmailid gmaili kontodel läinud rämpsposti)

Comments are currently closed.

See veebileht kasutab küpsiseid, mis aitavad teha lehe külastamise mugavamaks. Meie veebilehte külastades nõustute meiepoolse küpsiste kasutamisega.
Sain aru.